Back
Degraded

Site creation issue
Started 18 Jun at 06:05pm IST, resolved 18 Jun at 07:42pm IST.
app.instawp.io
Resolved
We have identified the minor work quickly and deployed it in production. Everything is back to normal.
Posted 18 Jun at 07:42pm IST.

Created
Few users have reported about failure of site creation especially when created from a snapshot. Our team has identified the issue and is working on the fix. ETA 30 mins to 1 hour.
Posted 18 Jun at 06:05pm IST.