Get in touch
Back
Resolved

Sites are not being created from Snapshots

Started .

app.instawp.io
Created

We had several users reporting about sites not being created from snapshots. The engineering team quickly resolved the issue. The incident was resolved within 2 hrs of identification of the first issue.

Posted .