Get in touch
Back
Resolved

Issues with site creation from Snapshots/Template

Started .

app.instawp.io
Created

We are investigating issues with site creation from snapshots and templates after the recent release. The team is working on a fix.

Update (1:03 pm UTC) : Issue fixed.

Posted .